Dear FireBoard users,
In order to further develope the need of Joomla for a robust forum, FireBoard component has been moved to its own new home and new name. You can find more information regarding the Kunena, the successor of FireBoard, at kunena.com. The current forum here will stay for some time more for referencing needs. You can find the FireBoard files under joomlacode.org and other files
Upgrading to Kunena is highly recommended!

Kunena! - To Speak!

A revolution is coming... Kunena - Swahili for: To Speak! THE Next generation of native Joomla based Forum ultra component. Forget what you know about Joomla based forums...
Amazingly Simple Lean and Clean Easier Customization
Kunena is about to redefine the world of Joomla! with the most simplistic ultra component out there. For ultimate performance based on state of the art development techniques, Kunena! is about to bring you... With an integrated plugin system that will allow you to extend Kunena beyond your wildest imaginations...
Nightly Build 1.0.5NB7 posted
TOPIC: Nightly Build 1.0.5NB7 posted
#54982
Nightly Build 1.0.5NB7 posted 9 Years, 1 Month ago  
Just posted the latest of our Alpha builds on http://joomlacode.org/gf/project/fireboard/frs/

[quote]This build contains various SQL and other fixes.
Major rework: Forum permissions check re-written. Saves SQL calls and should work all over the board including search.
New little feature: You can embed eBay items just like videos inside a user post.
We have also added an initial version of a Dev Team Credits page. This will be updated for the final release. [/quote]

[b]To see a high level list of all changes implemented look here:[/b]
http://joomlacode.org/gf/project/fireboard/scmsvn/?action=browse&path=%2Fdevelopment%2F&view=log

You can find the install packages in the \'UnderDevelopment\' folder.

While we don\'t do documentation on the nightly builds here a few tips to get you going:

This latest build does a full install or upgrade of virtually any prior FireBoard release, without manual intervention. No need to run SQL scripts of any sort.

IF you want to preserve the configuration information of a prior install (1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4) you must first install and run the fbconverter component. See here: http://www.bestofjoomla.com/component/op...38/catid,6/id,53567/
(Not required for test sites upgrading from the prior nightly build)

Once you have run the converter make sure you backup, backup, backup and once again

THESE ALPHA BUILDS ARE NOT FOR PRODUCTION SITES!

Once you have a good backup, backup, backup simply uninstall the current version of FireBoard on your test server.

The rest is identical for both install and upgrade.

Install the latest com_fireboard package through the joomla component installer. During the install the installer will recognize whether this is a fresh install or and upgrade and will perform the required tasks including all SQL upgrades to the database.

We have added a lot more error checking to the database portion of FireBoard to quickly know about failing queries that would have been skipped over in most prior releases and nobody knew about it. So if you get an error message from a database call, we consider that helpful at this point in time, as it tells us what went wrong rather than hiding it from you and us. Just make sure you get us the detailed information of the error message.

There are a few known issues: The hits counters are not displayed correctly for some threads and there are some selection fields missing in the backend. We know they why for both but have not had a chance to fix them.

Overall we have put several hundred hours into 1.0.5 so far. It is not perfect but is already getting much better and more stable than any prior release.

Thanks a lot in your help testing these pre-builds! Please make sure you share all the versions of products/packages you are using when reporting a problem. Most issues are related to specific versions and are virtually impossible to find without that.
#54982
Nightly Build 1.0.5NB7 posted 9 Years, 1 Month ago  
Just posted the latest of our Alpha builds on http://joomlacode.org/gf/project/fireboard/frs/

[quote]This build contains various SQL and other fixes.
Major rework: Forum permissions check re-written. Saves SQL calls and should work all over the board including search.
New little feature: You can embed eBay items just like videos inside a user post.
We have also added an initial version of a Dev Team Credits page. This will be updated for the final release. [/quote]

[b]To see a high level list of all changes implemented look here:[/b]
http://joomlacode.org/gf/project/fireboard/scmsvn/?action=browse&path=%2Fdevelopment%2F&view=log

You can find the install packages in the \'UnderDevelopment\' folder.

While we don\'t do documentation on the nightly builds here a few tips to get you going:

This latest build does a full install or upgrade of virtually any prior FireBoard release, without manual intervention. No need to run SQL scripts of any sort.

IF you want to preserve the configuration information of a prior install (1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4) you must first install and run the fbconverter component. See here: http://www.bestofjoomla.com/component/op...38/catid,6/id,53567/
(Not required for test sites upgrading from the prior nightly build)

Once you have run the converter make sure you backup, backup, backup and once again

THESE ALPHA BUILDS ARE NOT FOR PRODUCTION SITES!

Once you have a good backup, backup, backup simply uninstall the current version of FireBoard on your test server.

The rest is identical for both install and upgrade.

Install the latest com_fireboard package through the joomla component installer. During the install the installer will recognize whether this is a fresh install or and upgrade and will perform the required tasks including all SQL upgrades to the database.

We have added a lot more error checking to the database portion of FireBoard to quickly know about failing queries that would have been skipped over in most prior releases and nobody knew about it. So if you get an error message from a database call, we consider that helpful at this point in time, as it tells us what went wrong rather than hiding it from you and us. Just make sure you get us the detailed information of the error message.

There are a few known issues: The hits counters are not displayed correctly for some threads and there are some selection fields missing in the backend. We know they why for both but have not had a chance to fix them.

Overall we have put several hundred hours into 1.0.5 so far. It is not perfect but is already getting much better and more stable than any prior release.

Thanks a lot in your help testing these pre-builds! Please make sure you share all the versions of products/packages you are using when reporting a problem. Most issues are related to specific versions and are virtually impossible to find without that.
#54984
Re:Nightly Build 1.0.5NB7 posted 9 Years, 1 Month ago  
I just tried to install and got

Invalid checksum for file \"###################################################### // MOS Intruder Alerts defined(\'_VALID_MOS\'\" : 32874 calculated, 0 expected

Ill try again though
#54985
Re:Nightly Build 1.0.5NB7 posted 9 Years, 1 Month ago  
hope this will be the last one, the nest one should be stable, or wouldn\'t it ;)

I am selfish, cause I want to see you start working on v2 as soon as humanly possible :)
#54986
Re:Nightly Build 1.0.5NB7 posted 9 Years, 1 Month ago  
[b]blakey87 wrote:[/b]
[quote]I just tried to install and got

Invalid checksum for file \"###################################################### // MOS Intruder Alerts defined(\'_VALID_MOS\'\" : 32874 calculated, 0 expected

Ill try again though[/quote]

This does not look like a FireBoard problem. I have run installs and upgrades on J1.0.15 and J1.5.4 without any issues.
#54987
Re:Nightly Build 1.0.5NB7 posted 9 Years, 1 Month ago  
[b]Stasys wrote:[/b]
[quote]hope this will be the last one, the nest one should be stable, or wouldn\'t it ;)

I am selfish, cause I want to see you start working on v2 as soon as humanly possible :)[/quote]

Mee too! But then again major bugs need to get fixed. Believe me it is not really fun to cleanup bugs that others have created over the years.
We want 1.0.5 to be the best release and make 2.0 even better.
#54988
Re:Nightly Build 1.0.5NB7 posted 9 Years, 1 Month ago  
[b]blakey87 wrote:[/b]
[quote]I just tried to install and got

Invalid checksum for file \"###################################################### // MOS Intruder Alerts defined(\'_VALID_MOS\'\" : 32874 calculated, 0 expected

Ill try again though[/quote]

Cool I guess my server only like zip file, I was using the tar.gz file

Let the testing begin
#54991
Re:Nightly Build 1.0.5NB7 posted 9 Years, 1 Month ago  
does this include the discuss bot fix by chance?

also, any chance of getting the animated avatars fixed as well? We see them working here on this board but they don\'t seem to work for anyone else.

(off to install)
#54992
Re:Nightly Build 1.0.5NB7 posted 9 Years, 1 Month ago  
[ul]A ton of images were missing from default_gray and other btw...[/ul]
[indent][size=1]
not a big deal, but probably something to fix before going to a beta.[/size][/indent]

[ul]still getting the missing fireboard config file for the discuss bot.[/ul]

[indent][size=1]
dropped the config file in and it gets rid of the error, but the discuss icon doesn\'t show up in articles.[/size][/indent]

[ul]user rankings aren\'t showing up.[/ul]
#54997
Re:Nightly Build 1.0.5NB7 posted 9 Years, 1 Month ago  
[b]JDuc wrote:[/b]
[quote]does this include the discuss bot fix by chance?

(off to install)[/quote]

The discussbot is a separate package from another author. I have had a chance to fix the joomap plug in and the latest post module but not the discussbot. Might want to contact the author.
When I am done fixing FB1.0.5 I might get a chance to look into discussbot. Please realize that my time on this is limited. I have put several hundred hours into this project so far and I could spend hundreds more fixing broken or not fulling working addons or plugins.
BTW aside from the cofig file compatibility the discussbot needs various fixes - it generates tons of warning and fills up your server error log.
#54998
Re:Nightly Build 1.0.5NB7 posted 9 Years, 1 Month ago  
Hi, I am the \'joomap plug\' author.

Please let me know the update/bug so that I can correct it next version.

PM me pls.


[b]BTW[/b], which Discussbot are you talking about ? The one by \'Objectclarity\' ?
http://www.bestofjoomla.com/component/option,com_extensions/page,show_extension/adid,41/catid,5/Itemid,67/
Page: 123... 5