Dear FireBoard users,
In order to further develope the need of Joomla for a robust forum, FireBoard component has been moved to its own new home and new name. You can find more information regarding the Kunena, the successor of FireBoard, at kunena.com. The current forum here will stay for some time more for referencing needs. You can find the FireBoard files under joomlacode.org and other files
Upgrading to Kunena is highly recommended!

Kunena! - To Speak!

A revolution is coming... Kunena - Swahili for: To Speak! THE Next generation of native Joomla based Forum ultra component. Forget what you know about Joomla based forums...
Amazingly Simple Lean and Clean Easier Customization
Kunena is about to redefine the world of Joomla! with the most simplistic ultra component out there. For ultimate performance based on state of the art development techniques, Kunena! is about to bring you... With an integrated plugin system that will allow you to extend Kunena beyond your wildest imaginations...
Nightly Build 1.0.5NB6 posted
TOPIC: Nightly Build 1.0.5NB6 posted
#54379
Nightly Build 1.0.5NB6 posted 9 Years, 4 Months ago  
Just posted the latest of our Alpha builds on
http://joomlacode.org/gf/project/fireboard/frs/

You can find the install packages in the \'UnderDevelopment\' folder.

While we don\'t do documentation on the nightly builds here a few tips to get you going:

This latest build does a full install or upgrade of virtually any prior FireBoard release, without manual intervention. No need to run SQL scripts of any sort.

IF you want to preserve the configuration information of a prior install (1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4) you must first install and run the fbconverter component. See here:
http://www.bestofjoomla.com/component/op...38/catid,6/id,53567/
(Not required for test sites upgrading from the prior nightly build)

Once you have run the converter make sure you backup, backup, backup and once again

THESE ALPHA BUILDS ARE NOT FOR PRODUCTION SITES!

Once you have a good backup, backup, backup simply uninstall the current version of FireBoard on your test server.

The rest is identical for both install and upgrade.

Install the latest com_fireboard package through the joomla component installer. During the install the installer will recognize whether this is a fresh install or and upgrade and will perform the required tasks including all SQL upgrades to the database.

We have added a lot more error checking to the database portion of FireBoard to quickly know about failing queries that would have been skipped over in most prior releases and nobody knew about it. So if you get an error message from a database call, we consider that helpful at this point in time, as it tells us what went wrong rather than hiding it from you and us. Just make sure you get us the detailed information of the error message.

There are a few known issues: The hits counters are not displayed correctly for some threads and there are some selection fields missing in the backend. We know they why for both but have not had a chance to fix them.

Overall we have put several hundred hours into 1.0.5 so far. It is not perfect but is already getting much better and more stable than any prior release.

Thanks a lot in your help testing these pre-builds! Please make sure you share all the versions of products/packages you are using when reporting a problem. Most issues are related to specific versions and are virtually impossible to find without that.
#54379
Nightly Build 1.0.5NB6 posted 9 Years, 4 Months ago  
Just posted the latest of our Alpha builds on
http://joomlacode.org/gf/project/fireboard/frs/

You can find the install packages in the \'UnderDevelopment\' folder.

While we don\'t do documentation on the nightly builds here a few tips to get you going:

This latest build does a full install or upgrade of virtually any prior FireBoard release, without manual intervention. No need to run SQL scripts of any sort.

IF you want to preserve the configuration information of a prior install (1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4) you must first install and run the fbconverter component. See here:
http://www.bestofjoomla.com/component/op...38/catid,6/id,53567/
(Not required for test sites upgrading from the prior nightly build)

Once you have run the converter make sure you backup, backup, backup and once again

THESE ALPHA BUILDS ARE NOT FOR PRODUCTION SITES!

Once you have a good backup, backup, backup simply uninstall the current version of FireBoard on your test server.

The rest is identical for both install and upgrade.

Install the latest com_fireboard package through the joomla component installer. During the install the installer will recognize whether this is a fresh install or and upgrade and will perform the required tasks including all SQL upgrades to the database.

We have added a lot more error checking to the database portion of FireBoard to quickly know about failing queries that would have been skipped over in most prior releases and nobody knew about it. So if you get an error message from a database call, we consider that helpful at this point in time, as it tells us what went wrong rather than hiding it from you and us. Just make sure you get us the detailed information of the error message.

There are a few known issues: The hits counters are not displayed correctly for some threads and there are some selection fields missing in the backend. We know they why for both but have not had a chance to fix them.

Overall we have put several hundred hours into 1.0.5 so far. It is not perfect but is already getting much better and more stable than any prior release.

Thanks a lot in your help testing these pre-builds! Please make sure you share all the versions of products/packages you are using when reporting a problem. Most issues are related to specific versions and are virtually impossible to find without that.
#54382
Re:Nightly Build 1.0.5NB6 posted 9 Years, 4 Months ago  
For the last build, I backed up my config file, uninstalled the old alpha, then installed the new one. Then dropped my config file in and it didn\'t pick any of it up. However, this config file is from 1.0.4 I believe?Not sure if that\'s related to, for instance, the discuss bot selection menu not showing?

I should just have to do the same thing here, right?

Leme see if I can explain better.

Was running 1.0.4, updated to a 1.0.5 alpha but just uninstalling then reinstalling. The tool was no available then.

Then, when I went to update to a new alpha, I backed up the config file, uninstalled the old alpha, installed the new alpha, dropped the config file in and noticed that none of my configurations were saved.

I guess I\'ve missed a step somewhere? Should I go ahead and run the tool?
#54383
Re:Nightly Build 1.0.5NB6 posted 9 Years, 4 Months ago  
Starting with 1.0.5NB4 the code will not look for a config file - only a database table. The settings you saved in NB4 and NB5 are already in the db and therefore don\'t need the converter. Only if you want to use a config file from 1.0.4 or before, you need to run the converter. You can do that at any time. Simply copy a config file into the path and run the converter, all current database settings will be overridden by the converter with the settings from the config file. You should never need to do this again after that.

Hope this helps!
#54384
Re:Nightly Build 1.0.5NB6 posted 9 Years, 4 Months ago  
Thanks!

So then if I understand this right, when I went from 1.0.4 to the first alpha that I ran, and I set all the config information in the alpha, then it\'s already created the db tables and I\'m good to go!

Thanks again! (runs off to test)
#54385
Re:Nightly Build 1.0.5NB6 posted 9 Years, 4 Months ago  
Yes, you should have all the settings in the db already.
#54388
Re:Nightly Build 1.0.5NB6 posted 9 Years, 4 Months ago  
ok - installed!

just one issue, while the drop down box is present now for the discuss bot, when I go to an article, I see the following instead of the discuss image: Error, missing fireboard config file!

I\'m sure it\'s just a configuration issue on my end. Any insight?
#54393
Re:Nightly Build 1.0.5NB6 posted 9 Years, 4 Months ago  
[quote][b]subfighter wrote:[/b]what is your setup joomla version?[/quote]

Took a hint from your sig and added my info as well...though it\'s showing up twice for both of us...strange?

Wonder if it\'s a Joomla 1.5 issue?
#54394
Re:Nightly Build 1.0.5NB6 posted 9 Years, 4 Months ago  
[b]JDuc wrote:[/b]
[quote][quote][b]subfighter wrote:[/b]what is your setup joomla version?[/quote]

Took a hint from your sig and added my info as well...though it\'s showing up twice for both of us...strange?

Wonder if it\'s a Joomla 1.5 issue?[/quote]

yeah i noticed that 2 and it removed the First Letter.. BUG :dry:
#54397
Re:Nightly Build 1.0.5NB6 posted 9 Years, 4 Months ago  
[b]JDuc wrote:[/b]
[quote]ok - installed!

just one issue, while the drop down box is present now for the discuss bot, when I go to an article, I see the following instead of the discuss image: Error, missing fireboard config file!

I\'m sure it\'s just a configuration issue on my end. Any insight?[/quote]

Sounds like the discussbot needs a revision too. It won\'t find the config file, because there is none starting with 1.0.5 as all the config data is inside the database.

There is a work around available though: Copy your old config file into the fireboard path. FB wont use it but it will make the discussbot find it.
#54399
Re:Nightly Build 1.0.5NB6 posted 9 Years, 4 Months ago  
[quote][b]fxstein wrote:[/b]
There is a work around available though: Copy your old config file into the fireboard path. FB wont use it but it will make the discussbot find it.[/quote]

Dropped the 1.0.4 config file back in the FTP folder. The image shows up now and when I click it, it takes me to the forum. However, it doesn\'t enter the article as a thread in the correct forum nor can I see the article. I\'m presented with this error:

[size=2][quote]The server encountered an unexpected condition which prevented it from fulfilling the request.
The script had an error or it did not produce any output. If there was an error, you should be able to see it in the error log. [/quote][/size]

Another issue, it appears that the \'View this persons profile\' image wasn\'t included in this build? Anyone else have this issue?
Page: 123... 7