Dear FireBoard users,
In order to further develope the need of Joomla for a robust forum, FireBoard component has been moved to its own new home and new name. You can find more information regarding the Kunena, the successor of FireBoard, at kunena.com. The current forum here will stay for some time more for referencing needs. You can find the FireBoard files under joomlacode.org and other files
Upgrading to Kunena is highly recommended!

Kunena! - To Speak!

A revolution is coming... Kunena - Swahili for: To Speak! THE Next generation of native Joomla based Forum ultra component. Forget what you know about Joomla based forums...
Amazingly Simple Lean and Clean Easier Customization
Kunena is about to redefine the world of Joomla! with the most simplistic ultra component out there. For ultimate performance based on state of the art development techniques, Kunena! is about to bring you... With an integrated plugin system that will allow you to extend Kunena beyond your wildest imaginations...
Nightly Build 1.0.5NB5 posted
TOPIC: Nightly Build 1.0.5NB5 posted
#54105
Nightly Build 1.0.5NB5 posted 9 Years, 2 Months ago  
Just posted the latest of our Alpha builds on

http://joomlacode.org/gf/project/fireboard/frs/

You can find the install packages in the \'UnderDevelopment\' folder.

While we don\'t do documentation on the nightly builds here a few tips to get you going:

This latest build does a full install or upgrade of virtually any prior FireBoard release, without manual intervention. No need to run SQL scripts of any sort.

IF you want to preserve the configuration information of a prior install you must first install and run the fbconverter component. See here:

http://www.bestofjoomla.com/component/option,com_fireboard/func,view/Itemid,38/catid,6/id,53567/

Once you have run the converter make sure you backup, backup, backup and once again

THESE ALPHA BUILDS ARE NOT FOR PRODUCTION SITES!

Once you have a good backup, backup, backup B) simply uninstall the current version of FireBoard on your test server.

The rest is identical for both install and upgrade.

Install the latest com_fireboard package through the joomla component installer. During the install the installer will recognize whether this is a fresh install or and upgrade and will perform the required tasks including all SQL upgrades to the database.

We have added a lot more error checking to the database portion of FireBoard to quickly know about failing queries that would have been skipped over in most prior releases and nobody knew about it. So if you get an error message from a database call, we consider that helpful at this point in time, as it tells us what went wrong rather than hiding it from you and us. Just make sure you get us the detailed information of the error message.

There are a few known issues: The hits counters are not displayed correctly for some threads and there are some selection fields missing in the backend. We know they why for both but have not had a chance to fix them.

Overall we have put several hundred hours into 1.0.5 so far. It is not perfect but is already getting much better and more stable than any prior release.

Thanks a lot in your help testing these pre-builds! Please make sure you share all the versions of products/packages you are using when reporting a problem. Most issues are related to specific versions and are virtually impossible to find without that.
#54105
Nightly Build 1.0.5NB5 posted 9 Years, 2 Months ago  
Just posted the latest of our Alpha builds on

http://joomlacode.org/gf/project/fireboard/frs/

You can find the install packages in the \'UnderDevelopment\' folder.

While we don\'t do documentation on the nightly builds here a few tips to get you going:

This latest build does a full install or upgrade of virtually any prior FireBoard release, without manual intervention. No need to run SQL scripts of any sort.

IF you want to preserve the configuration information of a prior install you must first install and run the fbconverter component. See here:

http://www.bestofjoomla.com/component/option,com_fireboard/func,view/Itemid,38/catid,6/id,53567/

Once you have run the converter make sure you backup, backup, backup and once again

THESE ALPHA BUILDS ARE NOT FOR PRODUCTION SITES!

Once you have a good backup, backup, backup B) simply uninstall the current version of FireBoard on your test server.

The rest is identical for both install and upgrade.

Install the latest com_fireboard package through the joomla component installer. During the install the installer will recognize whether this is a fresh install or and upgrade and will perform the required tasks including all SQL upgrades to the database.

We have added a lot more error checking to the database portion of FireBoard to quickly know about failing queries that would have been skipped over in most prior releases and nobody knew about it. So if you get an error message from a database call, we consider that helpful at this point in time, as it tells us what went wrong rather than hiding it from you and us. Just make sure you get us the detailed information of the error message.

There are a few known issues: The hits counters are not displayed correctly for some threads and there are some selection fields missing in the backend. We know they why for both but have not had a chance to fix them.

Overall we have put several hundred hours into 1.0.5 so far. It is not perfect but is already getting much better and more stable than any prior release.

Thanks a lot in your help testing these pre-builds! Please make sure you share all the versions of products/packages you are using when reporting a problem. Most issues are related to specific versions and are virtually impossible to find without that.
#54111
Re:Nightly Build 1.0.5NB5 posted 9 Years, 2 Months ago  
[b]fxstein wrote:[/b]
[quote]
IF you want to preserve the configuration information of a prior install you must first install and run the fbconverter component. See here:

http://www.bestofjoomla.com/component/option,com_fireboard/func,view/Itemid,38/catid,6/id,53567/[/quote]

Including from another SVN intall?
#54112
Re:Nightly Build 1.0.5NB5 posted 9 Years, 2 Months ago  
[b]JDuc wrote:[/b]
[quote][b]fxstein wrote:[/b]
[quote]
IF you want to preserve the configuration information of a prior install you must first install and run the fbconverter component. See here:

http://www.bestofjoomla.com/component/option,com_fireboard/func,view/Itemid,38/catid,6/id,53567/[/quote]

Including from another SVN intall?[/quote]

Sorry should have been more specific:

Run converter if you want to test the upgrade from FB 1.0.0-1.0.4

The last three NBs have had the config in the database already.
#54113
Re:Nightly Build 1.0.5NB5 posted 9 Years, 2 Months ago  
fxstein was faster :laugh:
#54115
Re:Nightly Build 1.0.5NB5 posted 9 Years, 2 Months ago  
[color=#FF6600][b]UNDER INVESTIGATION[/b][/color]

Ok - just did the install and got the following:

[quote]Warning: Could not load latest Version record.\\nDB function failed with error number 1054
Unknown column \'versiondate\' in \'field list\' SQL=SELECT `version`, `versiondate`, `installdate`, `build`, `versionname` FROM `jos_fb_version` ORDER BY `id` DESC LIMIT 1;
SQL =

SELECT
`version`,
`versiondate`,
`installdate`,
`build`,
`versionname`
FROM `jos_fb_version`
ORDER BY `id` DESC LIMIT 1;

in /xxxx/components/com_fireboard/sources/fb_debug.php on line 43[/quote]

Might this be expected since you were saying that this version included a change to update the version number?

Also, a number of the SQL queries failed. Do I need to post which ones failed to help troubleshoot?

Joomla: 1.0.15
FB: v1.0.5NB5_b357_20
Apache
PHP: 5.2.2
MySQL: 4.1.11
#54116
Re:Nightly Build 1.0.5NB5 posted 9 Years, 2 Months ago  
[color=#008000][b]NOT AN FB BUG[/b][/color]

I had installed 1.0.4 stable on my J1.5.3 testing site and likewise moved my database tables over and tested. On 1.0.4 stable, the only option that I could find that did not work was the move thread function.

I installed the converter (which completed without error) and uninstalled 1.0.4. I installed v1.0.5NB5_b357_20 and during the installation I received the following error:
[quote]Fatal error: Maximum execution time of 30 seconds exceeded in /.../public_html/15/libraries/joomla/filesystem/archive/zip.php on line 292[/quote]

I tried several different installs and the same error keeps coming up with different line numbers... 291, 292, 301...

Joomla: 1.5.3
FB: v1.0.5NB5_b357_20
Apache: 2.2.9 (Unix)
PHP: 5.2.6
MySQL: 5.0.51a-community
VPS LAMP Server
#54117
Re:Nightly Build 1.0.5NB5 posted 9 Years, 2 Months ago  
[b]powderburned wrote:[/b]
[quote]Fatal error: Maximum execution time of 30 seconds exceeded in /.../public_html/15/libraries/joomla/filesystem/archive/zip.php on line 292[/quote]

Try to increase the \"max_execution_time\" in the php.ini file, eg. from 30 to 60 (or higher if needed). You find this file on the server. Don\'t forget to restart the Apache demon/service after modifying...
#54119
Re:Nightly Build 1.0.5NB5 posted 9 Years, 2 Months ago  
Is this a downgrade from 1.1.0 because i\'m extremely confused how 1.1.0 can come out before 1.0.5 if you guys could let me know whats going on that would be great.
#54120
Re:Nightly Build 1.0.5NB5 posted 9 Years, 2 Months ago  
1.1 has been dropped - 2.0 will arrive later this year.
#54121
Re:Nightly Build 1.0.5NB5 posted 9 Years, 2 Months ago  
1.1 was going to be the next release. They have made so many changes (completely rewrote the code basically) That they are canceling 1.1 and calling it 2.0 instead. 1.0.5 is just a final release of the 1.0.x version. It\'s not completed yet and is still in Alpha. It will fix a number of the bugs that are still present in 1.0.4. Do NOT install it if you\'re not willing to run an Alpha. Wait for it to come out as a final release.
Page: 123... 5