Dear FireBoard users,
In order to further develope the need of Joomla for a robust forum, FireBoard component has been moved to its own new home and new name. You can find more information regarding the Kunena, the successor of FireBoard, at kunena.com. The current forum here will stay for some time more for referencing needs. You can find the FireBoard files under joomlacode.org and other files
Upgrading to Kunena is highly recommended!

Kunena! - To Speak!

A revolution is coming... Kunena - Swahili for: To Speak! THE Next generation of native Joomla based Forum ultra component. Forget what you know about Joomla based forums...
Amazingly Simple Lean and Clean Easier Customization
Kunena is about to redefine the world of Joomla! with the most simplistic ultra component out there. For ultimate performance based on state of the art development techniques, Kunena! is about to bring you... With an integrated plugin system that will allow you to extend Kunena beyond your wildest imaginations...
MySQL minimum version requirements & fb_debug.php
TOPIC: MySQL minimum version requirements & fb_debug.php
#57822
MySQL minimum version requirements & fb_debug.php 9 Years, 2 Months ago  
I would like to shine some light on some of the error messages some of you are getting when fb_debug.php throws an error message.

1.0.5 has for the very first time a rather complete set of error checks built in. In past versions FireBoard would ignore database errors and as such would behave very strange when certain SQL statements would fail. The new version alerts on every hard error. Those error prevent the code from working. eliminating the error report does not help as the application is basically broken.

Aside from a small issue we had with the fb_config table and its forced recreations on a few select platform (all of that has been fixed in the latest RC1 build) all other database errors are now confirmed due to outdated database server SW.

For your information: MySQL has declared 3.23, 4.0 and 4.1 as END OF LIFE - NO LONGER SUPPORTED

These versions should be depreciated in all production environments. They lack some of the most basic SQL strategies and as such do not support the latest optimizations we built into 1.0.5
One of these features are derived tables that allow us to collapse multiple SQL calls into a single one. Everybody running 5.x and 6.x and above will want those as it does make FireBoard faster and lighter on CPU. We would have to remove the performance optimizations out of the code to support these very old MySQL versions. In addition the extra SQL demand put forth by the SEO optimizations (pagination) would result in even worse performance, if it had to be implemented on MySQL 4.x or earlier.

I realize we need to update the minimum version requirements of our documentation. We are discussing internally how we will proceed with this.

At this point in time I recommend that if you are running MySQL version less than 5.0 you should not consider running 1.0.5 until you have upgraded the MySQL version.
#57822
MySQL minimum version requirements & fb_debug.php 9 Years, 2 Months ago  
I would like to shine some light on some of the error messages some of you are getting when fb_debug.php throws an error message.

1.0.5 has for the very first time a rather complete set of error checks built in. In past versions FireBoard would ignore database errors and as such would behave very strange when certain SQL statements would fail. The new version alerts on every hard error. Those error prevent the code from working. eliminating the error report does not help as the application is basically broken.

Aside from a small issue we had with the fb_config table and its forced recreations on a few select platform (all of that has been fixed in the latest RC1 build) all other database errors are now confirmed due to outdated database server SW.

For your information: MySQL has declared 3.23, 4.0 and 4.1 as END OF LIFE - NO LONGER SUPPORTED

These versions should be depreciated in all production environments. They lack some of the most basic SQL strategies and as such do not support the latest optimizations we built into 1.0.5
One of these features are derived tables that allow us to collapse multiple SQL calls into a single one. Everybody running 5.x and 6.x and above will want those as it does make FireBoard faster and lighter on CPU. We would have to remove the performance optimizations out of the code to support these very old MySQL versions. In addition the extra SQL demand put forth by the SEO optimizations (pagination) would result in even worse performance, if it had to be implemented on MySQL 4.x or earlier.

I realize we need to update the minimum version requirements of our documentation. We are discussing internally how we will proceed with this.

At this point in time I recommend that if you are running MySQL version less than 5.0 you should not consider running 1.0.5 until you have upgraded the MySQL version.
#58286
Re:MySQL minimum version requirements & fb_debug.php 9 Years, 2 Months ago  
I already install 1.0.5 RC1 on my joomla 1.14.0 in MSQ 4.0. I don\'t have any idea how to upgrade from MSQ 4 to 5. So the other option is trying to use a lower Fireboard version, but which one is the one that works with MSQ 4? And what do I have to do to erase the 1.0.5 RC1 version? so, actually is \'downgrading\'.
#59175
Re:MySQL minimum version requirements & fb_debug.p 9 Years, 1 Month ago  
[b]aleforum wrote:[/b]
[quote]I already install 1.0.5 RC1 on my joomla 1.14.0 in MSQ 4.0. I don\'t have any idea how to upgrade from MSQ 4 to 5. So the other option is trying to use a lower Fireboard version, but which one is the one that works with MSQ 4? And what do I have to do to erase the 1.0.5 RC1 version? so, actually is \'downgrading\'.[/quote]

Please check with your hosting provider on how to get off an unsupported MySQL version. All Major hosting providers have long upgraded to 5.x and 6.x.
#59291
Re:MySQL minimum version requirements & fb_debug.php 9 Years, 1 Month ago  
Hello,

I\'m trying to install the latest release of FB, but I do, an error message appears saying that the extension is too old and I need to turn the legacy plugin on.

I don\'t understand why...

I\'m on Joomla! 1.5.6.

Does someone have an idea ?

Thanks ,

Stef
#59304
Re:MySQL minimum version requirements & fb_debug.php 9 Years, 1 Month ago  
FireBoard requires J1.5.x to be running in Legacy mode .. it is not a Joomla native component.

To understand legacy mode in J 1.5.6 take a look here:
http://docs.joomla.org/What_is_%22legacy_mode%22%3F

simply enable legacy mode through the plugin manager in Joomla Admin [img size=519]http://fireboard.bestofjoomla.com/images/fbfiles/images/legacy.JPG[/img]
#60385
Re:MySQL minimum version requirements & fb_debug.p 9 Years, 1 Month ago  
hi guys,

im using fireboard 1.0.5RC2 right now and i got a problem here to ask..

is this fireboard fix the tag code like HIDE, CENTER?
#61346
MySQL Errors, please advise! 9 Years ago  
[b]OK below is an error page that showed when I think I asked Fireboard to show me Recent Discussions. I upgraded from 1.04 to the latest 1.05 rc2. It has been working fine with a few quirks such as preferred viewing of last or firts post not working. I have Joomla 1.0.15 and checked to see if I had the right SQL which this is what is says in my phpinfo file --> Client API version, 5.0.45, then when I use system info I also get this --> Client API library version 4.1.22 and Client API version again at 5.0.45... however I upgraded my board from 1.04 to the 1.05 rc2 because I really thought it was at 5.0.45... does anyone know which it is from what I posted above?

The board was working fine for 2 weeks before this error showed up below, and it is not showing up all the time...hmm.. I gave you the specs above and I am using the default_ex template and Community Board 1.1. Below is the first error I got, then below that I list the others. What is the issue? I thought my SQL was OK. Is the version info I got above correct, is it above 5? Do I need to downgrade back to FB 1.04? My site is almost unsurfable at this time. I have also contacted my host, and they don\'t seem to have a clue.
[/b]

Welcome, UserName
Show Latest Posts | My Profile | Logout | Announcements variable value
$0 \"
key value
$file \"/home/thefrien/public_html/components/com_fireboard/sources/fb_debug.php\"
$line \"36\"
$function \"debug_callstackinfo\"
[args] Nested Array
\"
$1 \"
key value
$file \"/home/thefrien/public_html/components/com_fireboard/sources/fb_debug.php\"
$line \"45\"
$function \"trigger_dberror\"
[args] Nested Array
\"
$2 \"
key value
$file \"/home/thefrien/public_html/components/com_fireboard/template/default_ex/latestx.php\"
$line \"200\"
$function \"check_dberror\"
[args] Nested Array
\"
$3 \"
key value
$file \"/home/thefrien/public_html/components/com_fireboard/fireboard.php\"
$line \"758\"
[args] Nested Array
$function \"include\"
\"
$4 \"
key value
$file \"/home/thefrien/public_html/index.php\"
$line \"236\"
[args] Nested Array
$function \"require_once\"
\"

Fatal error: Unable to load messages.\\nDB function failed with error number 2013
Lost connection to MySQL server during query SQL=SELECT a.id, a.parent, a.thread, a.catid, a.subject, a.name, a.time, a.topic_emoticon, a.locked, a.ordering, a.userid , a.moved, u.avatar FROM jos_fb_messages AS a LEFT JOIN jos_comprofiler AS u ON u.user_id = a.userid WHERE a.thread IN (\'36734\',\'17545\',\'34181\',\'20472\',\'33032\',\'36735\',\'28233\',\'5635\',\'36443\',\'36625\',\'36637\',\'36733\',\'36683\',\'35520\',\'36703\',\'15140\',\'23999\',\'23997\',\'18998\',\'36705\',\'36704\',\'19126\',\'16301\',\'32281\',\'18554\',\'36631\',\'36679\',\'36664\',\'36663\',\'22169\') AND a.id NOT IN (\'36734\',\'17545\',\'34181\',\'20472\',\'33032\',\'36735\',\'28233\',\'5635\',\'36443\',\'36625\',\'36637\',\'36733\',\'36683\',\'35520\',\'36703\',\'15140\',\'23999\',\'23997\',\'18998\',\'36705\',\'36704\',\'19126\',\'16301\',\'32281\',\'18554\',\'36631\',\'36679\',\'36664\',\'36663\',\'22169\') AND a.hold=0
SQL =
SELECT
a.id,
in /home/thefrien/public_html/components/com_fireboard/sources/fb_debug.php on line 37

[b]*****This error is after submitting a post*****[/b]

Welcome, UserName
Show Latest Posts | My Profile | Logout | Announcements TFK Forum Warm Welcome
Care to Share? (1 viewing) UserName ,

Your message has been successfully posted
variable value
$0 \"
key value
$file \"/home/thefrien/public_html/components/com_fireboard/sources/fb_debug.php\"
$line \"36\"
$function \"debug_callstackinfo\"
[args] Nested Array
\"
$1 \"
key value
$file \"/home/thefrien/public_html/components/com_fireboard/sources/fb_debug.php\"
$line \"45\"
$function \"trigger_dberror\"
[args] Nested Array
\"
$2 \"
key value
$file \"/home/thefrien/public_html/components/com_fireboard/sources/fb_link.class.php\"
$line \"250\"
$function \"check_dberror\"
[args] Nested Array
\"
$3 \"
key value
$file \"/home/thefrien/public_html/components/com_fireboard/template/default/post.php\"
$line \"488\"
$function \"GetLatestPostAutoRedirectHTML\"
$class \"fb_link\"
$type \"::\"
[args] Nested Array
\"
$4 \"
key value
$file \"/home/thefrien/public_html/components/com_fireboard/fireboard.php\"
$line \"608\"
[args] Nested Array
$function \"include\"
\"
$5 \"
key value
$file \"/home/thefrien/public_html/index.php\"
$line \"236\"
[args] Nested Array
$function \"require_once\"
\"

Fatal error: Unable to retrieve latest post.\\nDB function failed with error number 2006
MySQL server has gone away SQL=SELECT a.thread AS thread, max(a.id) AS latest_id, max(a.catid) AS catid, count(*) AS totalmessages FROM jos_fb_messages AS a, (SELECT max(thread) AS thread FROM jos_fb_messages WHERE id=36764) AS b WHERE a.thread = b.thread AND a.hold = 0 GROUP BY a.thread
SQL =
SELECT a.thread AS thread, max(a.id) AS latest_id, max(a.catid) AS catid, count(*) AS totalmessages
FROM jos_fb_messages AS a,
(SELECT max(thread) AS thread FROM jos_fb_messages WHERE id=36764) AS b
WHERE a.thread = b.thread AND a.hold = 0
GROUP BY a.thread
in /home/thefrien/public_html/components/com_fireboard/sources/fb_debug.php on line 37

[b]These are the other errors I am getting:[/b]

DB function failed with error number 2006
MySQL server has gone away SQL=SELECT session_id FROM jos_session WHERE session_id = \'31980631508a53cd3282a56b518db88a\'
SQL =
SELECT session_id
FROM jos_session
WHERE session_id = \'31980631508a53cd3282a56b518db88a\'


Error 503 - Service Temporarily Unavailable
This error means that the web server is currently unable to handle your request due to a temporary overload.
Please try to reload the webpage in a few seconds.

If you are the webmaster of this website and you see this error often please contact your web hosting company support for more information.

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@mysite.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
#62552
Re:MySQL Errors, please advise! 8 Years, 11 Months ago  
Update here: I have posted this on another active thread, but wanted to also update this thread that I resolved the above issues by moving to a host that provided the correct version of mySql.

Once I moved my site to another host that I verified was using mysql 5 or above, all the errors I was having that are listed in my prior post stopped. MySql at the old host was not high enough to run FB 1.0.5rc2.

So All I can say is double check that sql and make sure because I thought my sql was above as my host told me it was, but this is what I found out.

Client API library version 4.1.22
Client API version again at 5.0.45 <-- my host said this was mysql version. It was NOT, it was the above 4.1.22 and each time I tried to verify it they would never answer my direct questions. I moved my site and I no longer have DB errors, 503 errors, etc...

Good luck!
Page: 1