Dear FireBoard users,
In order to further develope the need of Joomla for a robust forum, FireBoard component has been moved to its own new home and new name. You can find more information regarding the Kunena, the successor of FireBoard, at kunena.com. The current forum here will stay for some time more for referencing needs. You can find the FireBoard files under joomlacode.org and other files
Upgrading to Kunena is highly recommended!

Kunena! - To Speak!

A revolution is coming... Kunena - Swahili for: To Speak! THE Next generation of native Joomla based Forum ultra component. Forget what you know about Joomla based forums...
Amazingly Simple Lean and Clean Easier Customization
Kunena is about to redefine the world of Joomla! with the most simplistic ultra component out there. For ultimate performance based on state of the art development techniques, Kunena! is about to bring you... With an integrated plugin system that will allow you to extend Kunena beyond your wildest imaginations...
[Solved] Upgrade SQL error
TOPIC: [Solved] Upgrade SQL error
#20218
[Solved] Upgrade SQL error 10 Years, 2 Months ago  
When trying execute the Fireboard_102_to_1.0.3.Stable.sql file I get following error:

[code:1]Error

SQL query:

-- __^__ __^__
- - ( ___ ) ----------------------------------------- - ( ___ ) -- | / | SQL Upgrade | \\ |
-- | / | Fireboard 1.0.2 to 1.0.3 Stable | \\ |
-- |___| Rename jos_ to your db prefix |___|
- - ( _____ ) ----------------------------------------- - ( _____ ) --
/* Alter table in Second database */ ALTER TABLE `mos_fb_categories` CHANGE `moderated` `moderated` tinyint( 4 ) NOT NULL DEFAULT \'0\' AFTER `alert_admin` ,
ADD COLUMN `headerdesc` text NOT NULL AFTER `description` ,
ADD COLUMN `class_sfx` varchar( 20 ) NOT NULL AFTER `headerdesc` ,
CHANGE `id_last_msg` `id_last_msg` int( 10 ) NOT NULL DEFAULT \'0\' AFTER `class_sfx` ,
COMMENT = \'\';

MySQL said: Documentation
#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near \'--( ___ )------------------------------------------( ___ )
-- | / | \' at line 1 [/code:1]

What went wrong and can I fix it?
#20218
[Solved] Upgrade SQL error 10 Years, 2 Months ago  
When trying execute the Fireboard_102_to_1.0.3.Stable.sql file I get following error:

[code:1]Error

SQL query:

-- __^__ __^__
- - ( ___ ) ----------------------------------------- - ( ___ ) -- | / | SQL Upgrade | \\ |
-- | / | Fireboard 1.0.2 to 1.0.3 Stable | \\ |
-- |___| Rename jos_ to your db prefix |___|
- - ( _____ ) ----------------------------------------- - ( _____ ) --
/* Alter table in Second database */ ALTER TABLE `mos_fb_categories` CHANGE `moderated` `moderated` tinyint( 4 ) NOT NULL DEFAULT \'0\' AFTER `alert_admin` ,
ADD COLUMN `headerdesc` text NOT NULL AFTER `description` ,
ADD COLUMN `class_sfx` varchar( 20 ) NOT NULL AFTER `headerdesc` ,
CHANGE `id_last_msg` `id_last_msg` int( 10 ) NOT NULL DEFAULT \'0\' AFTER `class_sfx` ,
COMMENT = \'\';

MySQL said: Documentation
#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near \'--( ___ )------------------------------------------( ___ )
-- | / | \' at line 1 [/code:1]

What went wrong and can I fix it?
#20220
Re:Upgrade SQL error 10 Years, 2 Months ago  
mmm how did you try to do the SQL query? just try to do it from a file without all this header, start at /* alter table....
Seems like it didn\'t like the header....
#20222
Re:Upgrade SQL error 10 Years, 2 Months ago  
Before I imported the file and didn\'t changed the header. Now I removed the header and get this error:

[code:1]Error

SQL query:

/* Alter table in Second database */ ALTER TABLE `mos_fb_categories` CHANGE `moderated` `moderated` tinyint( 4 ) NOT NULL DEFAULT \'0\' AFTER `alert_admin` ,
ADD COLUMN `headerdesc` text NOT NULL AFTER `description` ,
ADD COLUMN `class_sfx` varchar( 20 ) NOT NULL AFTER `headerdesc` ,
CHANGE `id_last_msg` `id_last_msg` int( 10 ) NOT NULL DEFAULT \'0\' AFTER `class_sfx` ,
COMMENT = \'\';

MySQL said: Documentation
#1054 - Unknown column \'id_last_msg\' in \'mos_fb_categories\' [/code:1]

What to do now? Damn, gotta take a SQL course soon ;)
#20224
Re:Upgrade SQL error 10 Years, 2 Months ago  
Well not sure on this one are you sure you had the last 1.0.2 RC2 version and did correctly the database upgrade before? don\'t know why id_last_msg is not there...
Maybe someone from Fb team knows
good luck

ps: mos_fb instead of jos_fb, that is normal?
#20225
Re:Upgrade SQL error 10 Years, 2 Months ago  
Are you sure , Your fireboard version. I think your fb version was 1.0.1
#20226
Re:Upgrade SQL error 10 Years, 2 Months ago  
Yep, very sure. But maybe dartagnan32 is right and the previous database upgrade didn\'t went well. I remember I had some problems before. Checking things now...
#20237
Re:Upgrade SQL error 10 Years, 2 Months ago  
Can anyone help me with my SQL error, I was asked to post it in this thread:

I am upgrading from 1.0.1 to the current 1.0.3 stable

Below is my error:

[code:1]SQL query:

/* Alter table in Second database */ ALTER TABLE `jos_fb_categories` ADD COLUMN `headerdesc` text NOT NULL AFTER `description` ,
ADD COLUMN `class_sfx` varchar( 20 ) NOT NULL AFTER `headerdesc` ,
ADD COLUMN `id_last_msg` int( 10 ) NOT NULL DEFAULT \'0\' AFTER `class_sfx` ,
ADD COLUMN `numTopics` mediumint( 8 ) NOT NULL DEFAULT \'0\' AFTER `id_last_msg` ,
ADD COLUMN `numPosts` mediumint( 8 ) NOT NULL DEFAULT \'0\' AFTER `numTopics` ,
ADD COLUMN `time_last_msg` int( 11 ) NULL AFTER `numPosts` ,
ADD KEY `msg_id` ( `id_last_msg` ) ,
COMMENT = \'\';



MySQL said:

#1060 - Duplicate column name \'headerdesc\' [/code:1]

I know nothing of SQL but I can follow simple instructions.
#20238
Re:Upgrade SQL error 10 Years, 2 Months ago  
SQL query:

Upgrades / Fireboard_101_to_1 .0 .3.Stable.sql

MySQL said: Documentation
#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near \'Upgrades/Fireboard_101_to_1.0.3.Stable.sql\' at line 1

Thats my error, no idea whats wrong.
#20239
Re:Upgrade SQL error 10 Years, 2 Months ago  
[b]RUFiO wrote:[/b]
[quote]SQL query:

Upgrades / Fireboard_101_to_1 .0 .3.Stable.sql

MySQL said: Documentation
#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near \'Upgrades/Fireboard_101_to_1.0.3.Stable.sql\' at line 1

Thats my error, no idea whats wrong.[/quote]

Are you trying to import the SQL file or are you copying/pasting the SQL statements into the SQL tab on PHPMyAdmin
#20241
Re:Upgrade SQL error 10 Years, 2 Months ago  
which should he be doing?
Page: 123