Dear FireBoard users,
In order to further develope the need of Joomla for a robust forum, FireBoard component has been moved to its own new home and new name. You can find more information regarding the Kunena, the successor of FireBoard, at kunena.com. The current forum here will stay for some time more for referencing needs. You can find the FireBoard files under joomlacode.org and other files
Upgrading to Kunena is highly recommended!

Kunena! - To Speak!

A revolution is coming... Kunena - Swahili for: To Speak! THE Next generation of native Joomla based Forum ultra component. Forget what you know about Joomla based forums...
Amazingly Simple Lean and Clean Easier Customization
Kunena is about to redefine the world of Joomla! with the most simplistic ultra component out there. For ultimate performance based on state of the art development techniques, Kunena! is about to bring you... With an integrated plugin system that will allow you to extend Kunena beyond your wildest imaginations...
If no jos_fb_groups, then I\'m at 1.00 for sure?
TOPIC: If no jos_fb_groups, then I\'m at 1.00 for sure?
#20342
If no jos_fb_groups, then I\'m at 1.00 for sure? 10 Years, 2 Months ago  
I need to determine what version I have before upgrading to 1.03. I could swear I upgraded to 1.01 when it was released. However, the upgrade instructions say to check for a jos_fb_groups table, and that if you have that, you have the 1.01 version. I don\'t have that. Does that mean I\'m wrong, and did not upgrade to 1.01? Or is it possible to be at 1.01 without that table, as I could swear I upgraded. Thanks for any help.
#20342
If no jos_fb_groups, then I\'m at 1.00 for sure? 10 Years, 2 Months ago  
I need to determine what version I have before upgrading to 1.03. I could swear I upgraded to 1.01 when it was released. However, the upgrade instructions say to check for a jos_fb_groups table, and that if you have that, you have the 1.01 version. I don\'t have that. Does that mean I\'m wrong, and did not upgrade to 1.01? Or is it possible to be at 1.01 without that table, as I could swear I upgraded. Thanks for any help.
#20347
Re:If no jos_fb_groups, then I\'m at 1.00 for sure? 10 Years, 2 Months ago  
I would presume 1.0.0 because that is the only version that table did not originally appear in. Make sure you backup your database first :).
#20636
Re:If no jos_fb_groups, then I\'m at 1.00 for sure? 10 Years, 2 Months ago  
Thanks for the reply. Is it possible that I \"partially\" upgraded to 1.01? I remember back when I did the upgrade to 1.01 (which I am 99% sure I did), the upgrade instructions were really confusing to me. A while after I did the upgrade, I remembered reading some posts here about something that needed to be done to the database in certain situations (some queries, I think). I got the sense that whether you needed to run the queries depended on how you arrived at 1.01 (clean install, upgrade from joomlaboard, etc.). Since I wasn\'t having any problems with the upgrade, and wasn\'t sure if the queries applied to me, I decided not to mess with it. So a few questions, if someone could be kind enough to indulge me:

1) Is it possible this (the \"partial\" upgrade of the files but not the database) is what I did, or would I have easily noticed it due to error messages, etc., when using the forum on my site?

2) If I did do this, is there any way to fix it? Will the 1.00 to 1.03 query work? Or do I need to go back and find the old 1.00 to 1.01 query? Or am I screwed now and it is too late? :dry:

Thanks for any help.
#20769
Re:If no jos_fb_groups, then I\'m at 1.00 for sure? 10 Years, 2 Months ago  
I would run 1.0.0 upgrade process. You may get SQL errors, but as long as they say \"duplicate\" in the error response, you are fine. Just continue executing the remaining SQL statements
#20968
Re:If no jos_fb_groups, then I\'m at 1.00 for sure? 10 Years, 2 Months ago  
Thanks palebluedot . . . you\'re everywhere in these forums. :)

I ended up getting all sorts of errors no matter which package I did. I stayed up late learning a bit more about SQL than I would have liked, but got things working by running the queries that worked in both upgrade paths, and then comparing my database structure to the sample structure in the upgrade package, and fixing the differences.

One thing I did notice was that the columns in jos__fb_users were in a different order between my database and the sample one. Does that matter (now, or as a possible source of trouble in a future upgrade)? It actually looks like mine more correctly reflect the order the queries in the package are putting it in, but I\'m no expert.
Page: 1