Dear FireBoard users,
In order to further develope the need of Joomla for a robust forum, FireBoard component has been moved to its own new home and new name. You can find more information regarding the Kunena, the successor of FireBoard, at kunena.com. The current forum here will stay for some time more for referencing needs. You can find the FireBoard files under joomlacode.org and other files
Upgrading to Kunena is highly recommended!

Kunena! - To Speak!

A revolution is coming... Kunena - Swahili for: To Speak! THE Next generation of native Joomla based Forum ultra component. Forget what you know about Joomla based forums...
Amazingly Simple Lean and Clean Easier Customization
Kunena is about to redefine the world of Joomla! with the most simplistic ultra component out there. For ultimate performance based on state of the art development techniques, Kunena! is about to bring you... With an integrated plugin system that will allow you to extend Kunena beyond your wildest imaginations...
Bug in ultimi messaggi
TOPIC: Bug in ultimi messaggi
#3577
Bug in ultimi messaggi 10 Years, 4 Months ago  
Salve,
quando clicco su ultimi messaggi, mi apre un Itemid che non corrisponde a quello del componente Fireboard.

Ad esempio l\'Itemid del componenente FireBoard è 83, mentre quando clicco mi fornisce 80 che non esiste e quindi quando voglio rispondere mi dice utente non registrato. (joomla si comporta in maniera corretta).

Sono andato nel file fireboard.php ed ho scoperto le righe che portano all\'errore:

[b]//check if the Itemid is set correctly

if ($Itemid == 1 or $Itemid == \"\")

{

$database->setQuery(\"select id from #__menu where link=\'index.php?option=com_fireboard\'\");

$Itemid=$database->loadResult();
}[/b]

Quando clicco su uno degli ultimi messaggi (anche anche cliccando dal modulo), l\'Itemid da 83 diventa 1 e quindi viene analizzato dall\'istruzione if che recupera l\'Itemid. Solo che l\'Itemid non è più 83 ma 80 e quindi non carica la pagina corretta. (tale errore l\'ho scoperto con degli echo $Identid; posti pre e post if).

Ho rimediato compensando l\'errore introdotto dal ciclo if (dovrei aggiungere nel mio caso +3 alla var $Itemid), ma è solo una toppa e non la soluzione al problema.
[b]
//check if the Itemid is set correctly

if ($Itemid == 1 or $Itemid == \"\")

{

$database->setQuery(\"select id from #__menu where link=\'index.php?option=com_fireboard\'\");

$Itemid=$database->loadResult();
$Itemid+=3;

}[/b]
[color=#0000FF][/color]

Qualcuno ha riscontrato lo stesso errore? (penso di si).
Trovata la soluzione?

Ringrazio

Post edited by: jnash, at: 2007/04/27 22:36
#3577
Bug in ultimi messaggi 10 Years, 4 Months ago  
Salve,
quando clicco su ultimi messaggi, mi apre un Itemid che non corrisponde a quello del componente Fireboard.

Ad esempio l\'Itemid del componenente FireBoard è 83, mentre quando clicco mi fornisce 80 che non esiste e quindi quando voglio rispondere mi dice utente non registrato. (joomla si comporta in maniera corretta).

Sono andato nel file fireboard.php ed ho scoperto le righe che portano all\'errore:

[b]//check if the Itemid is set correctly

if ($Itemid == 1 or $Itemid == \"\")

{

$database->setQuery(\"select id from #__menu where link=\'index.php?option=com_fireboard\'\");

$Itemid=$database->loadResult();
}[/b]

Quando clicco su uno degli ultimi messaggi (anche anche cliccando dal modulo), l\'Itemid da 83 diventa 1 e quindi viene analizzato dall\'istruzione if che recupera l\'Itemid. Solo che l\'Itemid non è più 83 ma 80 e quindi non carica la pagina corretta. (tale errore l\'ho scoperto con degli echo $Identid; posti pre e post if).

Ho rimediato compensando l\'errore introdotto dal ciclo if (dovrei aggiungere nel mio caso +3 alla var $Itemid), ma è solo una toppa e non la soluzione al problema.
[b]
//check if the Itemid is set correctly

if ($Itemid == 1 or $Itemid == \"\")

{

$database->setQuery(\"select id from #__menu where link=\'index.php?option=com_fireboard\'\");

$Itemid=$database->loadResult();
$Itemid+=3;

}[/b]
[color=#0000FF][/color]

Qualcuno ha riscontrato lo stesso errore? (penso di si).
Trovata la soluzione?

Ringrazio

Post edited by: jnash, at: 2007/04/27 22:36
#3587
Re:Bug in ultimi messaggi 10 Years, 4 Months ago  
Stessa cosa mi capita con /mambots/content/[b]fbdiscussbot.php[/b]

Ho compensato per richiamare la pag corretta.

riga 71

$Itemid+=3;


Ho provato ad eliminrare il menu al componente e ricrearlo di nuovo (da 83 Identid a 84), ma il risultato per lo script è sempre 80. Adesso devo compensare con un più 4.

Saluti
#3891
Re:Bug in ultimi messaggi 10 Years, 4 Months ago  
Scarica di nuovo il componente da questo sito. (hanno fatto delle piccole modifiche senza segnalarle)
Disinstalla fireboard, elimina le tavole dal db sql e reinstalla nuovamente.
Facci sapere ;)
Page: 1